Logo

Fast Text Format

Fast Text Format Tools

Die ultimative Sammlung blitzschneller Dienstprogramme zum Formatieren, Konvertieren und Optimieren Ihres Workflows.

Favoriten

Zuletzt verwendet

Kürzlich hinzugefügt

Text & Vergleich

Code & Formatierung

Base64-zu-Datei-Decoder

Base64-Zeichenfolgen oder Data-URIs wieder in herunterladbare Dateien (Bilder, PDFs, Dokumente, Audio) mit Sofortvorschau umwandeln.

Code-Verschönerer & Minifizierer

Formatieren, validieren und minimieren Sie Ihren JSON-, JavaScript-, CSS- und HTML-Code in eine saubere, lesbare Syntax.

Konfigurations-Konverter (TOML / INI / .env / JSON)

Konfigurationsdateien nahtlos zwischen TOML, INI, Java .properties, .env, YAML und JSON mit verschachtelter Schlüssel-Glättung konvertieren.

CSS-Formatierer & Minifizierer

CSS-Code mit benutzerdefinierter Einrückung formatieren, verschönern, validieren und minimieren.

Visuelle CSS-Generatoren

CSS-Code für Schlagschatten, Verläufe, Flexbox und Grid-Layouts visuell erstellen und exportieren.

CSV zu JSON/SQL

Konvertieren Sie CSV-Daten in JSON-Arrays oder SQL INSERT-Anweisungen.

cURL zu Fetch

Konvertieren Sie cURL-Befehle ganz einfach in JavaScript Fetch API-Code.

Docker Run zu Compose

docker run CLI-Befehle in saubere, produktionsreife docker-compose.yml-Konfigurationsdateien konvertieren.

GraphQL Explorer & Formatter

GraphQL-Abfragen, Mutationen, Subscriptions und SDL-Schemata verschönern, minimieren, validieren und mit AST-Operations- & Variablenanalyse inspizieren.

HTML- & XML-Formatierer

Formatieren, verschönern und minimieren Sie HTML- und XML-Code mit anpassbarer Einrückung und Syntaxbereinigung.

HTML zu JSX

Clientseitiges Tool zur Umwandlung von HTML-Tags/-Attributen in React-kompatibles JSX.

HTML zu Tailwind CSS

Standardmäßige Inline-Stile und CSS-Deklarationen in Tailwind-CSS-Utility-Klassen mit Live-Vorschau umwandeln.

JS-Obfuskator

Lesbaren JavaScript-Code in unleserlichen, minimierten Code zum Schutz der Programmlogik umwandeln.

JSON-Schema-Validator

Validieren Sie JSON-Nutzdaten anhand von JSON-Schema-Spezifikationen (Draft-07, 2020-12, Draft-04) mit Echtzeit-Fehlerpfaden und Keyword-Erklärungen.

JSON Stringify & Parse (.env-bereit)

Mehrzeilige JSON-Objekte mit einem Klick minimieren und als maskierten String für .env-Dateien, CLI-Argumente oder Code ausgeben oder zurück in JSON parsen.

JSON zu Code

Konvertieren Sie JSON-Objekte in typisierte Modelle für verschiedene Sprachen.

JSON-Baum-Viewer

JSON-Nutzdaten visuell prüfen, aufklappen, einklappen, durchsuchen und filtern mit Pfad-Inspektion.

JSONPath & JQ Evaluator

Fragen Sie JSON-Nutzdaten in Echtzeit mit standardmäßigem JSONPath (RFC 9535) oder JQ-Ausdrücken ab und transformieren Sie sie mit Tabellen- und Pfadansichten.

Markdown-Editor & Vorschau

Schreiben, bearbeiten und prüfen Sie Markdown in Echtzeit mit Live-HTML-Vorschau, Syntax-Styling und HTML-Export.

OpenAPI / Swagger Betrachter & Validator

Clientseitiger interaktiver Explorer und Validator für OpenAPI 3.0/3.1- und Swagger 2.0-Spezifikationen im YAML- oder JSON-Format.

Semantisches JSON-Diff

Vergleichen Sie zwei JSON-Dokumente semantisch ohne Berücksichtigung von Schlüsselreihenfolge oder Formatierung, mit visuellen Änderungen und RFC 6902 JSON-Patch-Export.

Source-Map-Viewer

Clientseitiges Tool zum Hochladen von .map-Dateien und De-Minifizieren von Stacktraces.

SQL Formatter

Formatieren, verschönern und minimieren Sie SQL-Abfragen für verschiedene SQL-Dialekte.

String maskieren & demaskieren

Maskieren (und demaskieren) Sie Anführungszeichen, Backslashes und Zeilenumbrüche sicher für JSON-Strings, SQL-Abfragen, HTML und Java/C#.

SVG-Optimierer

Rohen SVG-Code verkleinern.

SVG zu PNG/WEBP

Clientseitiges Tool zur Rasterung von SVG-Code oder -Dateien in herunterladbare Bilder über Canvas.

XML-Dienstprogramme

XML-Strings formatieren und verkleinern.

YAML <-> JSON

Konvertieren Sie sofort zwischen YAML und JSON.

Daten & Krypto

Generatoren & Dienstprogramme

.gitignore-Generator

Erstellen Sie umfassende, praxiserprobte .gitignore-Dateien für beliebige Programmiersprachen, Frameworks, Betriebssysteme und IDEs.

ASCII-Art-Generator

Konvertieren Sie Text in stilvolle ASCII-Art-Banner, Figlet-Typografie und dekorativen Monospace-Text.

Barcode-Generator

Clientseitiges Tool zur Erstellung linearer Barcodes (UPC, EAN, Code39) auf einem Canvas.

CHMOD-Berechtigungsrechner

Berechnen, konvertieren und überprüfen Sie Linux-Dateiberechtigungen mit visuellen Oktal- und Symbolmodi.

Farbkontrast

Prüfen Sie die WCAG-Farbkontrast-Zugänglichkeit.

Farbkonverter & Pipette

Wählen Sie Farben und konvertieren Sie zwischen HEX-, RGB-, HSL-, HSV- und CMYK-Formaten mit Live-Vorschau und Farbpaletten.

Cron-Ausdruck Generator & Decoder

Erstellen, bearbeiten und dekodieren Sie Cron-Zeitpläne in menschenlesbare Beschreibungen mit anstehenden Ausführungszeiten.

EXIF-Datenbetrachter & Bereiniger

Zeigen, analysieren und entfernen Sie EXIF-, Kamera- und GPS-Standort-Metadaten aus JPEG-, PNG- und WebP-Bildern lokal für absolute Privatsphäre.

Favicon-Generator

Standardbilder in universell kompatible .ico-Dateien konvertieren und Standard-Web-App-Symbolgrößen generieren.

Bild Base64

Bilddateien in Base64 Data URI-Strings und CSS background-image-Eigenschaften umwandeln.

Bild-Farbpaletten-Extraktor

Beliebiges Bild ablegen, um dominante HEX-, RGB- und HSL-Farbpaletten mit interaktiver Pipette sowie CSS-, Tailwind- und JSON-Export zu extrahieren.

Bildkomprimierer

Komprimieren und optimieren Sie JPEG-, PNG-, WEBP- und AVIF-Bilder lokal in Ihrem Browser.

LLM-Token-Zähler

Berechnen Sie Token-Verbrauch, schätzen Sie API-Kosten und analysieren Sie farbcodierte BPE-Token für OpenAI, Anthropic, Gemini und LLaMA.

Lorem-Ipsum-Generator

Erstellen Sie benutzerdefinierten Platzhaltertext nach Absätzen, Sätzen oder Wörtern für Mockups und Designs.

Markdown-Tabellengenerator

Ein visueller Rastereditor, der Benutzern das einfache Hinzufügen von Zeilen/Spalten ermöglicht und sofort eine perfekt formatierte Markdown-Tabellensyntax ausgibt.

Meta-Tag- & Open-Graph-Generator

SEO-Meta-Tags, Twitter Cards und Facebook Open Graph-Tags generieren und visuell in der Vorschau anzeigen.

Scheindatengenerator

Generieren Sie Hunderte Zeilen gefälschter Testdaten (Namen, E-Mails, Adressen, Daten, Kreditkarten) und exportieren Sie sie als CSV-, JSON- oder SQL-INSERT-Anweisungen für Datenbanktests.

Passwort-Generator

Erstellen Sie starke, sichere Passwörter und Passphrasen mit anpassbaren kryptografischen Algorithmen.

PDF-Werkzeuge

PDF-Seiten 100% lokal im Browser zusammenfügen, teilen, extrahieren, drehen und neu anordnen.

QR-Code-Generator

Erstellen Sie skalierbare, anpassbare und scannbare QR-Codes aus Text oder URLs mit sofortigem Download.

Regex-Tester und Builder

Testen Sie reguläre Ausdrücke mit Echtzeit-Match- und Capture-Gruppenhervorhebung, Aufschlüsselung der Syntaxerklärung und Testmodi mit mehreren Zeichenfolgen.

Robots.txt-Generator

Gültige robots.txt-Regeln, Crawler-Direktiven erstellen und KI-Scraper blockieren.

ULID-Generator & Decoder

Generieren und analysieren Sie lexikografisch sortierbare eindeutige Identifikatoren (ULID) mit Millisekunden-Präzision und monotoner Reihenfolge.

UUID / GUID Generator

Generieren Sie universell eindeutige Identifikatoren (UUID/GUID v1, v4, v7) im Batch mit benutzerdefinierter Formatierung.

XML-Sitemap-Generator

Gültige XML-Sitemaps mit benutzerdefinierten URLs, Aktualisierungsfrequenzen und Prioritäten für Suchmaschinen erstellen.

Finanzen & Einheiten

Netzwerk

CORS-Tester

Cross-Origin Resource Sharing (CORS)-Header und Preflight-Antworten für jede API oder URL testen, prüfen und debuggen.

Datenbank-Verbindungszeichenfolgen-Parser & Builder

Analysieren und erstellen Sie Datenbank-URIs für PostgreSQL, MySQL, MongoDB, Redis, SQLite und SQL Server mit Abfrageparametern und .env-Export.

DNS-Suche

Überprüfen Sie DNS-Einträge in Echtzeit.

HTTP-Header-Viewer

Zeigen Sie HTTP-Anforderungsheader an, die von Ihrem Browser gesendet werden.

Internet-Geschwindigkeitstest

Testen Sie Ihre Download- und Upload-Verbindungsgeschwindigkeit.

IP-Suche

Suchen Sie IP-Adressen und Geolokalisierungsdaten.

MAC-Anbieter-Suche

Identifizieren Sie Hardware-Anbieter anhand von MAC-Adressen.

RDAP-Abfrage

Domain- und IP-Registrierungsdaten, Registrar, Nameserver und DNSSEC-Status über RDAP abfragen.

Weiterleitungs- & Link-Trace

Gekürzte URLs aufdecken und vollständige HTTP-301/302-Weiterleitungsketten bis zum Endziel verfolgen.

SSL-Zertifikat-Prüfer

Prüfen Sie Live-SSL/TLS-Zertifikate, Ausstellerketten, Ablauf-Countdowns, SAN-Domains und Fingerabdrücke für jede Domain.

Subnetz-Rechner

Berechnen Sie CIDR-Netzwerkmasken und IP-Bereiche.

URL Parser

Analysieren, prüfen, bearbeiten und erstellen Sie vollständige URLs und Abfrageparameter.

User-Agent Parser

Extrahieren Sie Betriebssystem- und Browser-Informationen aus User-Agent-Strings.

Webhook-Tester

Webhook-Übermittlungen mit benutzerdefinierten Headern, HMAC-Signaturen und Live-Antwortprüfung senden, testen und debuggen.

WebSocket-Client & -Tester

In Echtzeit mit WebSocket-Servern (ws:// und wss://) verbinden, Text- oder JSON-Nachrichten senden, bidirektionale Frames prüfen und Latenz messen.

JSON-Schema-Validator

Validieren Sie JSON-Nutzdaten anhand von JSON-Schema-Spezifikationen (Draft-07, 2020-12, Draft-04) mit Echtzeit-Fehlerpfaden und Keyword-Erklärungen.

Draft-07
Ready 0 B
Ready 0 B
Valid Payload The JSON data fully conforms to the schema specification.
0 Errors
Validierungsfehlerdetails
#KeywordInstance Path (Data Pointer)Schema PathMessage

Anleitung

Fügen Sie links Ihre JSON-Schema-Definition und rechts Ihre JSON-Nutzdaten ein. Der Validator erkennt die Draft-Spezifikation (Draft-07, 2020-12 oder Draft-04) automatisch und prüft Pflichtfelder, Datentypen, Array-Beschränkungen und Definitionen in Echtzeit.

Häufig gestellte Fragen

Welche JSON-Schema-Entwurfsspezifikationen werden unterstützt?

Der Validator unterstützt die Spezifikationen JSON Schema Draft 2020-12, Draft-07 und Draft-04. Standardmäßig analysiert die automatische Erkennung den Stamm-URI <code>$schema</code> (z. B. <code>https://json-schema.org/draft/2020-12/schema</code> oder <code>http://json-schema.org/draft-07/schema#</code>) und wendet die entsprechende semantische Behandlung für exklusive Mindestbeträge, Schlüsselwörter und interne Referenzanker an.

Wie werden interne Referenzen ($ref) aufgelöst?

Interne Dokumentverweise, die als RFC 6901-JSON-Zeiger formatiert sind (z. B. <code>#/$defs/Address</code>, <code>#/definitions/User</code> oder beliebige relative Schemazeiger) werden innerhalb desselben Dokuments mit zirkulären Rekursionsschutzmaßnahmen dynamisch aufgelöst.

Welche Stringformate werden validiert?

Zu den standardmäßig integrierten semantischen Formaten gehören <code>email</code>, <code>uri</code>, <code>date-time</code> (RFC 3339 / ISO 8601), <code>date</code> (YYYY-MM-DD), <code>time</code> (HH:MM:SS), <code>ipv4</code>, <code>ipv6</code>, <code>uuid</code> (RFC 4122 v1-v5) und <code>hostname</code>.

Wie funktioniert die Validierung zusätzlicher Eigenschaften?

Wenn <code>additionalProperties: false</code> für ein Objektschema festgelegt ist, wird jede in der JSON-Nutzlast vorhandene Eigenschaft, die nicht explizit in <code>properties</code> deklariert ist und keinem regulären Ausdruck in <code>patternProperties</code> entspricht, als ungültige zusätzliche Eigenschaft gekennzeichnet.

Werden meine JSON-Daten oder mein JSON-Schema auf einen Remote-Server hochgeladen?

Nein. Die Validierung wird zu 100 % lokal in Ihrem Webbrowser mit clientseitigem JavaScript ausgeführt. Ihre vertraulichen Schemata, Test-Payloads, Kundendaten und API-Payloads verlassen niemals Ihren Computer.

Was ist ein Instanz-JSON-Zeigerpfad im Fehlerbericht?

Der Instanzpfad gibt die genaue hierarchische Position des ungültigen Werts innerhalb Ihrer JSON-Datennutzlast gemäß RFC 6901 an (z. B. identifiziert <code>/users/2/contact/email</code> die E-Mail-Eigenschaft des dritten Benutzerelements).

Keine Ergebnisse gefunden

Versuchen Sie, Ihre Suchbegriffe anzupassen.